]> Git — Sourcephile - julm/julm-nix.git/blob - homes/julm/hosts/oignon.nix
profiles: revamp
[julm/julm-nix.git] / homes / julm / hosts / oignon.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../home-manager/profiles/chat.nix
5 ../../../home-manager/profiles/developing.nix
6 ../../../home-manager/profiles/drawing.nix
7 ../../../home-manager/profiles/gaming.nix
8 ../../../home-manager/profiles/gnupg.nix
9 ../../../home-manager/profiles/graphical.nix
10 ../../../home-manager/profiles/networking.nix
11 ../../../home-manager/profiles/radio.nix
12 ../../../home-manager/profiles/science.nix
13 ../../../home-manager/profiles/video.nix
14 ../../../home-manager/profiles/yt-dlp.nix
15 ../../../home-manager/profiles/mpv.nix
16 ../../../home-manager/profiles/wireless.nix
17
18 ../../../home-manager/profiles/emacs.nix
19 ../../../home-manager/profiles/firefox.nix
20 ../../../home-manager/profiles/xmonad.nix
21 ../../../home-manager/profiles/ghc.nix
22
23 ../mails.nix
24 ];
25 programs.bash.shellAliases.riseup = "sudo ip netns exec riseup sudo -u $USER PULSE_SERVER=/run/user/$(id -u $USER)/pulse/native";
26 programs.gpg.homedir = "${config.home.homeDirectory}/files/sec/.gnupg";
27 home.sessionVariables = {
28 PASSWORD_STORE_DIR = "$HOME/files/sec/.password-store";
29 };
30 home.packages = [
31 pkgs.libreoffice
32 pkgs.calibre
33 pkgs.evince
34 pkgs.stig
35 pkgs.gthumb
36 pkgs.thunderbird
37 #pkgs.chromium
38 pkgs.fluidsynth
39 pkgs.gpsbabel
40 #(pkgs.qgis.override { extraPythonPackages = (ps: [
41 # ps.pyqt5_with_qtwebkit
42 #]); })
43 #pkgs.libva-utils
44 pkgs.pandoc
45 pkgs.texlive.combined.scheme-small
46 #pkgs.ristretto
47 pkgs.xfce.mousepad
48 #pkgs.mate.pluma
49 pkgs.wxmaxima
50 pkgs.espeak-ng
51 pkgs.iodine
52 #pkgs.qsynth
53 ];
54
55 /* Cannot be automounted
56 systemd.user.mounts = {
57 mnt-aubergine = {
58 Unit = {
59 Wants = [
60 "network-online.target"
61 "wireguard-wg-intra.target"
62 ];
63 After = [
64 "network-online.target"
65 "wireguard-wg-intra.target"
66 ];
67 };
68 Install = {
69 WantedBy = ["default.target"];
70 };
71 Mount = {
72 What = "julm@aubergine.wg:/";
73 Where = "/mnt/aubergine";
74 Type = "fuse.sshfs";
75 Options = lib.concatStringsSep "," [
76 "user"
77 "uid=julm"
78 "gid=users"
79 "allow_other"
80 "exec" # Override "user"'s noexec
81 "noatime"
82 "nosuid"
83 "noauto"
84 "dir_cache=no"
85 #"reconnect"
86 "x-gvfs-hide"
87 # Does not work for user mounts
88 #"x-systemd.automount"
89 "IdentityFile=/home/julm/.ssh/id_ed25519"
90 #"Compression=yes" # YMMV
91 # Disconnect approximately 2*15=30 seconds after a network failure
92 "ServerAliveCountMax=1"
93 "ServerAliveInterval=15"
94 ];
95 };
96 };
97 };
98 */
99 /*
100 Automounting does not work without root privileges
101 systemd.user.automounts = {
102 mnt-aubergine = {
103 Install = {
104 WantedBy = ["user.target"];
105 };
106 Unit = {
107 };
108 Automount = {
109 Where = "/mnt/aubergine";
110 TimeoutIdleSec = "5 min";
111 };
112 };
113 };
114 */
115 }