1 { pkgs, lib, config, ... }:
3 inherit (config) networking;
4 inherit (config.security) gnupg;
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
12 nix.gc.dates = "weekly";
13 nix.gc.options = "--delete-older-than 7d";
16 boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
18 "https://nixcache.reflex-frp.org"
19 "https://arm.cachix.org"
21 nix.binaryCachePublicKeys = [
22 "ryantrinkle.com-1:JJiAKaRv9mWgpVAz8dwewnZe0AzzEAzPkagE9SP5NWI="
23 "arm.cachix.org-1:5BZ2kjoL1q6nWhlnrbAl+G7ThY7+HaBRD9PZzqZkbnM="
27 # Avoid the use of systemd-run --user --scope tmux
28 # and let mosh work smoothly.
29 services.logind.killUserProcesses = false;
31 hardware.bluetooth.enable = true;
32 #services.blueman.enable = true;
34 documentation.nixos = {
35 enable = false; # NOTE: useless on a server, and CPU intensive.
39 # Rotate the consoles anti-clockwise.
43 environment.systemPackages = with pkgs; [
59 #iptables-nftables-compat