]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/profiles/systems/crossCompilation.nix
carotte: linux: enable WiFi dongle
[sourcephile-nix.git] / nixos / profiles / systems / crossCompilation.nix
1 { pkgs, lib, config, ... }:
2 {
3 nixpkgs.overlays = [
4 (final: super: {
5 gnupg = super.gnupg.override {
6 # Wants polkit which wants spidermonkey (slow to compile)
7 pcsclite = null;
8 };
9 systemd = super.systemd.override {
10 # Wants tpm2-tss which does not cross-compile
11 withTpm2Tss = false;
12 # Does not cross-compile :(
13 withEfi = false;
14 };
15 # https://logs.nix.samueldr.com/nixos/2019-07-23#2416964;
16 xorg = super.xorg.overrideScope' (ofinal: osuper: {
17 fontadobe100dpi = final.hello;
18 fontadobe75dpi = final.hello;
19 fontcursormisc = final.hello;
20 fontmiscmisc = final.hello;
21 });
22 # Perl's ModuleBuild does not cross-compile
23 # https://github.com/NixOS/nixpkgs/issues/66741#issuecomment-944831760
24 xdg-utils = final.hello;
25 procmail = final.hello;
26 noto-fonts-emoji = final.hello;
27 x11_ssh_askpass = final.hello;
28 dconf = super.dconf.overrideAttrs (old: {
29 doCheck = false;
30 });
31 # Need gobject-instrospection which does not cross-compile
32 arandr = final.hello;
33 # Depends on judy which does not cross-compile
34 stress-ng = final.hello;
35 hwinfo = final.hello;
36 # Fails to cross-compile: perl5.34.0-IO-Tty-armv7l-unknown-linux-gnueabihf
37 mosh = final.hello;
38 # error: Error loading target specification:
39 # Could not find specification for target "armv7l-unknown-linux-gnueabihf".
40 # Run `rustc --print target-list` for a list of built-in targets
41 gparted = final.hello;
42 })
43 ];
44 #environment.noXlibs = true;
45 fonts.fontconfig.enable = false;
46 # lesspipe does not cross-compile
47 programs.less.enable = lib.mkForce false;
48 programs.mosh.enable = false;
49 programs.traceroute.enable = false;
50 security.apparmor.enable = false;
51 services.udisks2.enable = false;
52 }