]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
nix: update to latest nixpkgs
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 inherit (config.security) gnupg;
5 in
6 {
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 # Avoid the use of systemd-run --user --scope tmux
13 # and let mosh work smoothly.
14 services.logind.killUserProcesses = false;
15
16 nix.gc.dates = "weekly";
17 nix.gc.options = "--delete-older-than 7d";
18 nix.extraOptions = ''
19 secret-key-files = ${gnupg.secrets."nix/binary-cache-key/1".path}
20 '';
21 security.gnupg.secrets."nix/binary-cache-key/1" = {
22 systemdConfig = {
23 before = [ "nix-daemon.service" ];
24 wantedBy = [ "nix-daemon.service" ];
25 };
26 };
27
28 documentation.nixos = {
29 enable = false; # NOTE: useless on a server, and CPU intensive.
30 };
31
32 boot.kernelParams = [
33 # Rotate the consoles anti-clockwise.
34 "fbcon=rotate:3"
35 ];
36
37 environment.systemPackages = with pkgs; [
38 cryptsetup
39 direnv
40 f3
41 file
42 fio
43 gdb
44 git
45 gptfdisk
46 #hey
47 home-manager
48 lm_sensors
49 rsync
50 smartctl-tbw
51 socat
52 sanoid
53 #iptables-nftables-compat
54 pkgs.gnupg
55 miniupnpc
56 audit
57 python
58 ];
59 }