]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
opengl: enable for using through ssh
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 inherit (config.security) gnupg;
5 in
6 {
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 nix.gc.dates = "weekly";
13 nix.gc.options = "--delete-older-than 7d";
14
15 # Avoid the use of systemd-run --user --scope tmux
16 # and let mosh work smoothly.
17 services.logind.killUserProcesses = false;
18
19 hardware.opengl.enable = true;
20
21 documentation.nixos = {
22 enable = false; # NOTE: useless on a server, and CPU intensive.
23 };
24
25 boot.kernelParams = [
26 # Rotate the consoles anti-clockwise.
27 "fbcon=rotate:3"
28 ];
29
30 environment.systemPackages = with pkgs; [
31 cryptsetup
32 direnv
33 f3
34 file
35 fio
36 gdb
37 git
38 gptfdisk
39 #hey
40 home-manager
41 lm_sensors
42 rsync
43 smartctl-tbw
44 socat
45 sanoid
46 #iptables-nftables-compat
47 pkgs.gnupg
48 miniupnpc
49 audit
50 python
51 ];
52 }