]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
losurdo: wireguard: fix service dependency loop
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 in
5 {
6 # This value determines the NixOS release with which your system is to be
7 # compatible, in order to avoid breaking some software such as database servers.
8 # You should change this only after NixOS release notes say you should.
9 system.stateVersion = "19.09"; # Did you read the comment?
10
11 nix.gc.dates = "weekly";
12 nix.gc.options = "--delete-older-than 7d";
13
14 /*
15 boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
16 nix.binaryCaches = [
17 "https://nixcache.reflex-frp.org"
18 "https://arm.cachix.org"
19 ];
20 nix.binaryCachePublicKeys = [
21 "ryantrinkle.com-1:JJiAKaRv9mWgpVAz8dwewnZe0AzzEAzPkagE9SP5NWI="
22 "arm.cachix.org-1:5BZ2kjoL1q6nWhlnrbAl+G7ThY7+HaBRD9PZzqZkbnM="
23 ];
24 */
25
26 # Avoid the use of systemd-run --user --scope tmux
27 # and let mosh work smoothly.
28 services.logind.killUserProcesses = false;
29
30 hardware.bluetooth.enable = true;
31 #services.blueman.enable = true;
32
33 documentation.nixos = {
34 enable = false; # NOTE: useless on a server, and CPU intensive.
35 };
36
37 boot.kernelParams = [
38 # Rotate the consoles anti-clockwise.
39 #"fbcon=rotate:3"
40 ];
41
42 environment.systemPackages = with pkgs; [
43 bluez
44 cryptsetup
45 direnv
46 f3
47 file
48 fio
49 gdb
50 git
51 gptfdisk
52 #hey
53 home-manager
54 lm_sensors
55 rsync
56 socat
57 sanoid
58 #iptables-nftables-compat
59 pkgs.gnupg
60 miniupnpc
61 audit
62 python
63 ];
64 }