]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
mermet: lock machine-id
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 nix.gc.dates = "weekly";
9 nix.gc.options = "--delete-older-than 7d";
10
11 /*
12 boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
13 nix.binaryCaches = [
14 "https://nixcache.reflex-frp.org"
15 "https://arm.cachix.org"
16 ];
17 nix.binaryCachePublicKeys = [
18 "ryantrinkle.com-1:JJiAKaRv9mWgpVAz8dwewnZe0AzzEAzPkagE9SP5NWI="
19 "arm.cachix.org-1:5BZ2kjoL1q6nWhlnrbAl+G7ThY7+HaBRD9PZzqZkbnM="
20 ];
21 */
22
23 # Avoid the use of systemd-run --user --scope tmux
24 # and let mosh work smoothly.
25 services.logind.killUserProcesses = false;
26
27 hardware.bluetooth.enable = true;
28 #services.blueman.enable = true;
29
30 documentation.nixos = {
31 enable = false; # NOTE: useless on a server, and CPU intensive.
32 };
33
34 boot.kernelParams = [
35 # Rotate the consoles anti-clockwise.
36 #"fbcon=rotate:3"
37 ];
38
39 # Setting the machine-id avoids to reencrypt all credentials
40 # when reinstalling NixOS on a new drive.
41 # Manually generated with : uuidgen | tr -d -
42 environment.etc.machine-id.source = ./machine-id.clear;
43
44 environment.systemPackages = with pkgs; [
45 bluez
46 cryptsetup
47 direnv
48 # f3 # broken
49 file
50 fio
51 gdb
52 git
53 gptfdisk
54 #hey
55 home-manager
56 lm_sensors
57 rsync
58 socat
59 sanoid
60 #iptables-nftables-compat
61 pkgs.gnupg
62 miniupnpc
63 audit
64 python
65 ];
66 }