]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
nix: rename { machines => hosts }
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 in
5 {
6 # This value determines the NixOS release with which your system is to be
7 # compatible, in order to avoid breaking some software such as database servers.
8 # You should change this only after NixOS release notes say you should.
9 system.stateVersion = "19.09"; # Did you read the comment?
10
11 # Avoid the use of systemd-run --user --scope tmux
12 # and let mosh work smoothly.
13 services.logind.killUserProcesses = false;
14
15 nix.gc.dates = "weekly";
16 nix.gc.options = "--delete-older-than 7d";
17
18 documentation.nixos = {
19 enable = false; # NOTE: useless on a server, and CPU intensive.
20 };
21
22 boot.kernelParams = [
23 # Rotate the consoles anti-clockwise.
24 "fbcon=rotate:3"
25 ];
26
27 environment.systemPackages = with pkgs; [
28 cryptsetup
29 direnv
30 f3
31 file
32 fio
33 gdb
34 git
35 gptfdisk
36 #hey
37 home-manager
38 lm_sensors
39 rsync
40 smartctl-tbw
41 socat
42 sanoid
43 #iptables-nftables-compat
44 gnupg
45 miniupnpc
46 audit
47 python
48 ];
49 }