]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
nix: cleanups
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 inherit (config.security) gnupg;
5 in
6 {
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 nix.gc.dates = "weekly";
13 nix.gc.options = "--delete-older-than 7d";
14
15 # Avoid the use of systemd-run --user --scope tmux
16 # and let mosh work smoothly.
17 services.logind.killUserProcesses = false;
18
19 hardware.bluetooth.enable = true;
20 #services.blueman.enable = true;
21
22 documentation.nixos = {
23 enable = false; # NOTE: useless on a server, and CPU intensive.
24 };
25
26 boot.kernelParams = [
27 # Rotate the consoles anti-clockwise.
28 #"fbcon=rotate:3"
29 ];
30
31 environment.systemPackages = with pkgs; [
32 bluez
33 cryptsetup
34 direnv
35 f3
36 file
37 fio
38 gdb
39 git
40 gptfdisk
41 #hey
42 home-manager
43 lm_sensors
44 rsync
45 smartctl-tbw
46 socat
47 sanoid
48 #iptables-nftables-compat
49 pkgs.gnupg
50 miniupnpc
51 audit
52 python
53 ];
54 }