]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/unbound.nix
mermet: unbound config following calomel.org's
[sourcephile-nix.git] / servers / mermet / unbound.nix
1 { pkgs, lib, config, ... }:
2 let inherit (config) users; in
3 {
4 networking.resolvconf.useLocalResolver = true;
5 services.unbound = {
6 enable = true;
7 # DOC: https://calomel.org/unbound_dns.html
8 extraConfig = ''
9 port: 53
10 verbosity: 1
11
12 # The file which contains the listing of primary root DNS servers.
13 # To be updated once every six months.
14 root-hints: /var/lib/unbound/named.root
15
16 # Do no answer id.server and hostname.bind queries.
17 hide-identity: yes
18 # Do not answer version.server and version.bind queries.
19 hide-version: yes
20
21 # Will trust glue only if it is within the servers authority.
22 # Harden against out of zone rrsets, to avoid spoofing attempts.
23 # Hardening queries multiple name servers for the same data to make
24 # spoofing significantly harder and does not mandate dnssec.
25 harden-glue: yes
26
27 # Require DNSSEC data for trust-anchored zones, if such data is absent, the
28 # zone becomes bogus. Harden against receiving dnssec-stripped data. If you
29 # turn it off, failing to validate dnskey data for a trustanchor will trigger
30 # insecure mode for that zone (like without a trustanchor). Default on,
31 # which insists on dnssec data for trust-anchored zones.
32 harden-dnssec-stripped: yes
33
34 # Use 0x20-encoded random bits in the query to foil spoof attempts.
35 # http://tools.ietf.org/html/draft-vixie-dnsext-dns0x20-00
36 #
37 # When Unbound sends a query to a remote server it sends the hostname
38 # string in random upper and lower characters. The remote server must
39 # resolve the hostname as if all the characters were lower case. The remote
40 # server must then send the query back to Unbound in the same random upper
41 # and lower characters that Unbound sent. If the characters of the hostname
42 # in the response are in the same format as the query then the dns-0x20
43 # check is satisfied.
44 # Attackers hoping to poison a Unbound DNS cache must therefore guess the
45 # mixed-case encoding of the query and the timing of the return dns answer
46 # in addition to all other fields required in a DNS poisoning attack.
47 # dns-0x20 increases the difficulty of the attack significantly.
48 #
49 # It may result in maybe 0.4% of domains getting no answers
50 # due to no support on the authoritative server side
51 use-caps-for-id: yes
52
53 #cache-min-ttl: 3600
54 cache-max-ttl: 86400
55
56 # Perform prefetching of close to expired message cache entries. If a client
57 # requests the dns lookup and the TTL of the cached hostname is going to
58 # expire in less than 10% of its TTL, unbound will (1st) return the IP of the
59 # host to the client and (2nd) pre-fetch the DNS request from the remote DNS server.
60 # This method has been shown to increase the amount of cached hits by
61 # local clients by 10% on average.
62 prefetch: yes
63
64 # Number of threads to create. 1 disables threading.
65 # This should equal the number of CPU cores in the machine.
66 num-threads: 4
67
68 # The number of slabs to use for cache and must be a power of 2 times the
69 # number of num-threads set above. more slabs reduce lock contention,
70 # but fragment memory usage.
71 msg-cache-slabs: 8
72 rrset-cache-slabs: 8
73 infra-cache-slabs: 8
74 key-cache-slabs: 8
75
76 # Increase the memory size of the cache. Use roughly twice as much rrset cache
77 # memory as you use msg cache memory. Due to malloc overhead, the total memory
78 # usage is likely to rise to double (or 2.5x) the total cache memory.
79 rrset-cache-size: 32m
80 msg-cache-size: 16m
81
82 # buffer size for UDP port 53 incoming (SO_RCVBUF socket option). This sets
83 # the kernel buffer larger so that no messages are lost in spikes in the traffic.
84 so-rcvbuf: 1m
85
86 # Enforce privacy of these addresses. Strips them away from answers.
87 # It may cause DNSSEC validation to additionally mark it as bogus.
88 # Protects against 'DNS Rebinding' (uses browser as network proxy).
89 # Only 'private-domain' and 'local-data' names are allowed
90 # to have these private addresses. No default.
91 private-address: 192.168.0.0/16
92 private-address: 172.16.0.0/12
93 private-address: 10.0.0.0/8
94
95 # Allow the domain (and its subdomains) to contain private addresses.
96 # local-data statements are allowed to contain private addresses too.
97 #private-domain: "home.lan"
98
99 # If nonzero, unwanted replies are not only reported in statistics, but also
100 # a running total is kept per thread. If it reaches the threshold, a warning
101 # is printed and a defensive action is taken, the cache is cleared to flush
102 # potential poison out of it. A suggested value is 10000000, the default is
103 # 0 (turned off). calomel.org thinks 10K is a good value.
104 unwanted-reply-threshold: 10000
105
106 # IMPORTANT FOR TESTING: If you are testing and setup NSD or BIND on
107 # localhost you will want to allow the resolver to send queries to localhost.
108 # Make sure to set do-not-query-localhost: yes.
109 do-not-query-localhost: no
110
111 # Should additional section of secure message also be kept clean of unsecure
112 # data. Useful to shield the users of this validator from potential bogus
113 # data in the additional section. All unsigned data in the additional section
114 # is removed from secure messages.
115 val-clean-additional: yes
116 '';
117 };
118 systemd.services.unbound.preStart = ''
119 install -m 444 -o unbound -g nogroup \
120 ${../../config/dns/named.root} \
121 /var/lib/unbound/named.root
122 '';
123 }