1 { pkgs, lib, config, ... }:
3 inherit (builtins.extraBuiltins) pass git;
4 inherit (pkgs.lib) unlinesAttrs types;
5 inherit (config) networking;
6 inherit (config.services) knot;
7 inherit (config) users;
8 # Use the Git commit time of the ${domain}.nix file to set the serial number.
9 # WARNING: the ${domain}.nix must be committed into Git for this to work.
10 # WARNING: this does not take other .nix into account, though they may contribute to the zone's data.
11 serial = domain: toString (git ./. [ "log" "-1" "--format=%ct" "--" (domain + ".nix") ]);
12 mermetIPv4 = "80.67.180.129";
13 domain = "autogeree.net";
16 security.acme.certs."${domain}" = {
17 email = "root+letsencrypt@${domain}";
21 group = users.groups.acme.name;
22 allowKeysForGroup = true;
24 dnsProvider = "rfc2136";
25 credentialsFile = pkgs.writeText "credentials" ''
26 RFC2136_NAMESERVER=127.0.0.1:5353
27 LEGO_EXPERIMENTAL_CNAME_SUPPORT=1
30 services.knot.zones."${domain}" = {
33 - id: acl_acme_challenge_autogeree_net
37 update-owner-match: equal
38 update-owner-name: [_acme-challenge.${domain}]
44 serial-policy: increment
46 notify: secondary_gandi
47 notify: secondary_muarf
50 acl: acl_acme_challenge_autogeree_net
52 dnssec-policy: ed25519
54 # TODO: increase the TTL once things have settled down
59 ; SOA (Start Of Authority)
61 ${serial domain} ; Serial number
64 1000h ; Expire (1000h)
75 mermet A ${mermetIPv4}
76 autoconfig A ${mermetIPv4}
84 submission A ${mermetIPv4}
86 chomsky A 91.216.110.36
89 ; SPF (Sender Policy Framework)
90 @ 3600 IN SPF "v=spf1 mx ip4:${mermetIPv4} -all"
91 @ 3600 IN TXT "v=spf1 mx ip4:${mermetIPv4} -all"
97 _git._tcp.git 18000 IN SRV 0 0 9418 git
99 ; CAA (Certificate Authority Authorization)
100 ; DOC: https://blog.qualys.com/ssllabs/2017/03/13/caa-mandated-by-cabrowser-forum
101 @ CAA 128 issue "letsencrypt.org"
104 /* Useless since the zone is public
105 services.unbound.extraConfig = ''
107 name: "autogeree.net"
108 stub-addr: 127.0.0.1@5353