]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
nix: move some pkgs to julm-nix
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 inherit (config.security) gnupg;
5 in
6 {
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 nix.gc.dates = "weekly";
13 nix.gc.options = "--delete-older-than 7d";
14
15 /*
16 boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
17 nix.binaryCaches = [
18 "https://nixcache.reflex-frp.org"
19 "https://arm.cachix.org"
20 ];
21 nix.binaryCachePublicKeys = [
22 "ryantrinkle.com-1:JJiAKaRv9mWgpVAz8dwewnZe0AzzEAzPkagE9SP5NWI="
23 "arm.cachix.org-1:5BZ2kjoL1q6nWhlnrbAl+G7ThY7+HaBRD9PZzqZkbnM="
24 ];
25 */
26
27 # Avoid the use of systemd-run --user --scope tmux
28 # and let mosh work smoothly.
29 services.logind.killUserProcesses = false;
30
31 hardware.bluetooth.enable = true;
32 #services.blueman.enable = true;
33
34 documentation.nixos = {
35 enable = false; # NOTE: useless on a server, and CPU intensive.
36 };
37
38 boot.kernelParams = [
39 # Rotate the consoles anti-clockwise.
40 #"fbcon=rotate:3"
41 ];
42
43 environment.systemPackages = with pkgs; [
44 bluez
45 cryptsetup
46 direnv
47 f3
48 file
49 fio
50 gdb
51 git
52 gptfdisk
53 #hey
54 home-manager
55 lm_sensors
56 rsync
57 socat
58 sanoid
59 #iptables-nftables-compat
60 pkgs.gnupg
61 miniupnpc
62 audit
63 python
64 ];
65 }