]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/system.nix
nix-serve: add on losurdo
[sourcephile-nix.git] / hosts / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 inherit (config.security) gnupg;
5 in
6 {
7 # This value determines the NixOS release with which your system is to be
8 # compatible, in order to avoid breaking some software such as database servers.
9 # You should change this only after NixOS release notes say you should.
10 system.stateVersion = "19.09"; # Did you read the comment?
11
12 nix.gc.dates = "weekly";
13 nix.gc.options = "--delete-older-than 7d";
14
15 # Avoid the use of systemd-run --user --scope tmux
16 # and let mosh work smoothly.
17 services.logind.killUserProcesses = false;
18
19 documentation.nixos = {
20 enable = false; # NOTE: useless on a server, and CPU intensive.
21 };
22
23 boot.kernelParams = [
24 # Rotate the consoles anti-clockwise.
25 "fbcon=rotate:3"
26 ];
27
28 environment.systemPackages = with pkgs; [
29 cryptsetup
30 direnv
31 f3
32 file
33 fio
34 gdb
35 git
36 gptfdisk
37 #hey
38 home-manager
39 lm_sensors
40 rsync
41 smartctl-tbw
42 socat
43 sanoid
44 #iptables-nftables-compat
45 pkgs.gnupg
46 miniupnpc
47 audit
48 python
49 ];
50 }