3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
8 nix.gc.dates = "weekly";
9 nix.gc.options = "--delete-older-than 7d";
12 boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
14 "https://nixcache.reflex-frp.org"
15 "https://arm.cachix.org"
17 nix.binaryCachePublicKeys = [
18 "ryantrinkle.com-1:JJiAKaRv9mWgpVAz8dwewnZe0AzzEAzPkagE9SP5NWI="
19 "arm.cachix.org-1:5BZ2kjoL1q6nWhlnrbAl+G7ThY7+HaBRD9PZzqZkbnM="
23 # Avoid the use of systemd-run --user --scope tmux
24 # and let mosh work smoothly.
25 services.logind.killUserProcesses = false;
27 hardware.bluetooth.enable = true;
28 #services.blueman.enable = true;
30 documentation.nixos = {
31 enable = false; # NOTE: useless on a server, and CPU intensive.
35 # Rotate the consoles anti-clockwise.
39 # Setting the machine-id avoids to reencrypt all credentials
40 # when reinstalling NixOS on a new drive.
41 # Manually generated with : uuidgen | tr -d -
42 environment.etc.machine-id.source = ./machine-id.clear;
43 environment.systemPackages = with pkgs; [
59 #iptables-nftables-compat